ActiveRecord CockroachDB Adapter

CockroachDB adapter for ActiveRecord 4 and 5. This is a lightweight extension of the PostgreSQL adapter that establishes compatibility with CockroachDB.

Installation

Add this line to your project's Gemfile:

gem 'activerecord-cockroachdb-adapter', '~> 0.2'

If you're using Rails 4.x, use the 0.1.x versions of this gem.

In database.yml, use the following adapter setting:

development:
  adapter: cockroachdb
  port: 26257
  host: <hostname>
  user: <username>

Modifying the adapter?

See CONTRIBUTING.md for more details on setting up the environment and making modifications.

Activerecord Cockroachdb Adapter

CockroachDB adapter for ActiveRecord.

Activerecord Cockroachdb Adapter Info

⭐ Stars 63
🔗 Source Code github.com
🕒 Last Update a year ago
🕒 Created 5 years ago
🐞 Open Issues 47
➗ Star-Issue Ratio 1
😎 Author cockroachdb