Pharo-LibVLC

Pharo version

Binding FFI of libvlc for Pharo

Install

  1. Install VLC 3.x.x

  2. In a Pharo 8 image

Metacello new
  baseline: 'VLC';
  repository: 'github://badetitou/Pharo-LibVLC';
  load.

You should be able to execute VLCLibrary uniqueInstance getVersion

Linux

If you work on linux, please check that libvlc and libvlccore are in your path. To do so, you can execute whereis libvlc and whereis libvlccore.

If the whereis command return something like:

  • libvlccore: /usr/lib/libvlccore.so → OK
  • libvlccore: → It means you didn't install correctly the libraries, or you used snap.
  • libvlccore: /usr/lib/libvlccore.so.x → It means you've installed a specific version of the library. To use it with pharo please create a symbolic link without the ".x" → ln -s /usr/lib/libvlccore.so.x /usr/lib/libvlccore.so

If you used snap to install vlc, the path might be '/snap/vlc/current/usr/lib'

Quick example

vlc := VLCLibrary uniqueInstance createVLCInstance.
"do not use accentuated characters for the path"
media := vlc createMediaFromPath: '/my/file/path.mp3'.
mediaPlayer := VLCLibrary uniqueInstance mediaPlayerNewFromMedia: media.
mediaPlayer play

Documentation

Pharo Libvlc

Binding ffi of libvlc for Pharo

Pharo Libvlc Info

⭐ Stars 12
🔗 Source Code github.com
🕒 Last Update a year ago
🕒 Created 3 years ago
🐞 Open Issues 2
➗ Star-Issue Ratio 6
😎 Author badetitou