Terraform Firebase Provider

Maintainers

This provider plugin is maintained by the Terraform team at HashiCorp.

Requirements

  • Terraform 0.10.x
  • Go 1.8 (to build the provider plugin)

Usage

# For example, restrict template version in 0.1.x
provider "firebase" {
  version = "~> 0.1"
}

Building The Provider

Clone repository to: $GOPATH/src/github.com/terraform-providers/terraform-provider-firebase

$ mkdir -p $GOPATH/src/github.com/terraform-providers; cd $GOPATH/src/github.com/terraform-providers
$ git clone [email protected]:eliaszs/terraform-provider-firebase.git

Enter the provider directory and build the provider

$ cd $GOPATH/src/github.com/terraform-providers/terraform-provider-firebase
$ make build

Using the provider

Fill in for each provider

Developing the Provider

If you wish to work on the provider, you'll first need Go installed on your machine (version 1.8+ is required). You'll also need to correctly setup a GOPATH, as well as adding $GOPATH/bin to your $PATH.

To compile the provider, run make build. This will build the provider and put the provider binary in the $GOPATH/bin directory.

$ make bin
...
$ $GOPATH/bin/terraform-provider-firebase
...

In order to test the provider, you can simply run make test.

$ make test

In order to run the full suite of Acceptance tests, run make testacc.

Note: Acceptance tests create real resources, and often cost money to run.

$ make testacc

Terraform Provider Firebase

Terraform Firebase provider

Terraform Provider Firebase Info

⭐ Stars 32
🔗 Homepage github.com
🔗 Source Code github.com
🕒 Last Update 10 months ago
🕒 Created 4 years ago
🐞 Open Issues 0
➗ Star-Issue Ratio Infinity
😎 Author elislusarczyk